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INTRODUCTION TO FLASH MX 
The purpose of this handout is to introduce and briefly explore several functions within Flash MX. Step-by-
step instructions for the different ways to animate are also included. References to more comprehensive 
treatments of the topics covered will be provided at the end of this document. 

Flash MX is a software program produced by Macromedia. Flash is primarily used for creating web-based 
animations and for making web pages more interactive. While Flash can be used for creating web pages 
from scratch, this is usually a project better-suited for web page creation software like Dreamweaver, 
FrontPage or GoLive. In addition to its animation capabilities Flash also has lots of drawing tools. Drawing 
shapes for animation directly within Flash is encouraged, though Flash's drawing capabilities are not as 
advanced as those of Adobe Illustrator, Fireworks or Freehand. 

Getting Started at CSSCR 
Flash MX is installed on all of the PC machines in Savery, room 143 of CSSCR. In order to start Flash 
either double-click on its icon on the desktop, or go to Start/Programs/Macromedia Flash MX/Flash MX. 

Layout 
When you start Flash MX, you are first given a box that will allow you to choose what type of file you 
would like to create.  Click “Flash Document”.  You will then be greeted with the screen shown below, 
referred to as the Authoring Environment. It is here that you can draw figures and shapes to be animated, 
edit these images, create layers of animation, and even preview animations. The elements on this screen are 
important for the functions to be described in this document. If you don't see some of the elements that are 
pictured in this figure, you may need to add them in from the Window menu on the Main Toolbar. For 
example, if you don't see all of those Drawing Tools on the left of the screen, go to Window and click 
Tools. If you don't see those Panels on the right, you can find the various panels to view under Window or 
you can load the default panel by choosing Window > Panel Sets > Default Layout. If the Timeline isn’t 
visible, click Window > Timeline from the Main Toolbar. 
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Drawing and Manipulating Shapes in Flash 
Flash’s drawing capabilities can be probably be described as ‘intermediate’, with more advanced capabilities 
than, say, the drawing toolbar in Microsoft Word but not what would be described as ‘state of the art.’ 
Macromedia has made a point of improving Flash’s drawing features in the newest versions of Flash. 

Like most of the descriptions you might read for Flash, discussions of its drawing features are oriented 
towards web page publishing. Drawing in Flash will produce vector-based graphics. These graphics are 
basically stored as the mathematical information necessary for a computer to redraw the image. This is 
opposed to bitmap or raster graphics which contain information for each pixel the shape occupies (Note: It 
is still possible to import and use bitmap graphics and pictures in Flash. See the manuals cited at the end of 
this document for instructions). Vector graphics can be displayed on a variety of output devices (i.e. web 
browsers) and they are subject to less variations in quality as the output device changes. They can also be 
easily resized and reshaped. Finally, vector-based graphics conserve overall file size. All of these advantages 
are useful for more efficient web page creations, where file size and multiple viewing choices are important 
considerations. In general, options that reduce file size are always preferred, as larger files tend to download 
and play at less than optimal speeds for particular internet browsers and machines your viewers may use. 

The Drawing Tools 
If you try to use the drawing tools, you will find that some of them work similarly to the way they work in 
other programs (Word, PowerPoint). For example, you might click on the Circle, the Square, the Line or the 
Brush Tool and find that drawing the respective shapes on the Stage is very straightforward. Notice that 
some of the buttons on the Drawing Toolbar change as you select different tools. These are options that are 
specific to the tool selected. Selecting the Square Tool will give you options for determining the square's 
inside color (fill), outside color (stroke) and the roundness of its corners.  The properties panel will also 
change depending on the tool selected, giving further options for adjustment. 
Selecting the Brush Tool gives you options for determining not only the stroke and fill of the brush's 
drawing, but also different aspects of the brush's mode, use pressure, size and shape.  
 
 
 

Determine the Stroke color here. 

Determine the Fill color here. 

The Brush Tool is selected. 

Aspects of the Brush, like mode, 
use pressure, size and shape. 
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Short definitions of the other tools are listed. Go ahead, explore!! 

The Pencil is for drawing shapes that are free 
hand. Notice that its options/modes allow you to 
constrain just how free-handed the shapes can 
get. 
 
 
 
 
 

The Eraser, well, erases. 
 
 
 
 

The Paint Bucket is used for enclosing areas 
within shapes with a pre-specified color. 
 
 
 
 

The Pen Tool is an advanced drawing tool that is 
difficult to describe. Try clicking several points on 
the Stage for one way to use it. Also try drawing 
more than one long line for possible use. Weird, 
huh? 
 
 
 
 

The Eye Dropper is used for copying fill and 
stroke attributes from one shape or line and 
applying these attributes to another shape. 
 

 

 

 

The Lasso is for selecting objects or portions of 
objects. 
 
 
 
 
 

The Black Arrow is for selecting objects and then, 
with a right-click on a selected object (or noticing 
the options on the Drawing Toolbar), scaling, 
rotating, smoothing, straightening or moving the 
object. 
 
 
 
 
 

The White Arrow (Subselect Tool) is for selecting 
and dragging or otherwise modifying the 
individual anchor points of an object (Definition: 
Anchor points are the outlining points for shapes 
drawn in Flash). 
 
 
 
 

The Ink Bottle is for changing the line and stroke 
attributes of shapes. 
 
 
 
 
 
 

The Text Tool is for adding letters and words to 
the Stage. 

 

The Drawing-Related Panels 
While you are playing with the Drawing Tools be aware that you have options for modifying the fill and 
stroke attributes of a selected shape and also adjusting its colors. These can be explored in the Properties 
Color Mixer, and Color Swatches Panels (located on the screen, or under Window). 

To modify text, experiment with the Text, Character and Text Options Panels. 

When you are in Flash MX, use the Help Panel above the Properties Panel (or go to Help > How Do I) to 
find tutorials relevant to what you are working on.  
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Symbols, Instances, Libraries and the Symbol-Editing Environment 
When you reach the point where you have drawn shapes that you have an interest in incorporating into an 
animation, you will want to know about Symbols and Instances. Symbols and Instances are Flash's way of 
economizing on file size. The logic is simple. If you have a shape that will appear more than once and 
perhaps in only slightly different formats (a bird shape that will be used to draw a family of birds varying in 
size and color), draw one bird, a Master Symbol. Then use this Master Symbol to create Instances of it on 
the Stage, one Instance perhaps being smaller than another, or of a different color, etc. By allowing Flash to 
store a Master Symbol with relatively small modifications made to its Instances that appear in the animation, 
you are reducing the file size of your animation (good job!), not to mention reducing your workload (smart 
job!). 
There are three types of Symbols: Graphics, Movie Clips and Buttons. Graphics are static images that are 
locked into Flash's Timeline (this makes them preview-able). Movie Clips are defined as animations that play 
independently of the overall animation, making them non-previewable but also reducing overall file-size. 
Buttons are the animations that respond to mouse events. It is difficult to tell the difference between 
Graphics and Movie Clips. Flash expert Phillip Kerman (SAMS: Teach Yourself Macromedia Flash 5 in 24 
Hours) says that in general it's better to use Movie Clips for everything, even static symbols, due to their 
tendency to reduce overall file size (p. 255). With this rule-of-thumb, there are only two symbols we will be 
concerned with: Movie Clips and Buttons. We'll discuss the rest of this section in terms of Movie Clips and 
refer to them again in the animation sections to be covered later. We’ll discuss Buttons in the section on 
interactivity. 

The easiest way to create a Symbol is to just draw it on the Flash Stage. Go ahead and draw something and 
then select it, maybe with the Lasso Tool. Then go to the Main Toolbar and click Insert > New Symbol, or 
just hit the F8 key. You should get a prompt that looks like this: 
 
 
 
 
 
 
 
 
Name this new Symbol and make sure its Behavior is set to Movie Clip. Then Click OK.  

What happened? Well, for starters, the selected shape has a different look to it. Its selection should now be 
indicated by a blue box. This is an Instance of your Symbol. Go ahead and move it around the Stage by 
dragging and dropping it with the mouse. Also notice that your major options at this point (when the 
Symbol is selected) are to adjust its scale and color. Feel free to also adjust the color properties of this 
Instance via the Effect Panel. Any of these changes will leave the Master Symbol unchanged. 

Flash will keep a Library of all of the Symbols you create for an animation file. You can view this Library 
and its contents by either typing Control-L or clicking Window > Library. This Library lists all of your 
Master Symbols, indicating whether they are a Movie Clip, a Button or a Graphic by the small icon beside 
their name. If you click the Options Button you will find several fairly self-explanatory functions for your 
Symbols. If you click on the Symbol, it appears in the Library’s Preview box.  
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Click on this Symbol so it appears in the Preview box. Now drag the Symbol’s image from the Preview box 
and drop it onto the Stage. You now have two Instances of the Symbol in your movie. Once on the Stage, 
each of these instances can be separately modified without disturbing the Master Symbol. 

Want to alter your Master Symbol? Double-click on either one of the Instances, the Symbol's image in the 
Preview box, or the graphic beside the Symbol in the Library. Or go to the Main Toolbar and click Edit > 
Edit Symbol. If all goes well you should be in Symbol-Editing Mode, as indicated by a noticeable change in 
the background (it’s not really the Stage anymore). You should also see a change in some text in the upper 
left-hand corner, which instead of reading Scene 1 should now read Scene 1 <your Symbol's name>. In 
Symbol-Editing Mode you can make global changes to your Symbols. Make some obvious change and then 
go back to your main Stage, by either clicking on Scene 1 or clicking Edit > Edit Document. The change 
you made to your Master Symbol should now be reflected in both of the Instances and in the Preview of the 
Symbol in the Library. 
 
You can use the tutorial on Symbols by clicking Help > Using Flash > Using symbols, instances, and library 
assets overview in the Help Panel. 

Layers 
One way to gain more control over your animation (what things move, what things don’t move) is through 
the use of Layers. Any given Layer can contain shapes, Symbols, sounds, etc. that have specified behaviors 
which won’t disturb what might be going on in another Layer. The main qualification of this statement is 
that Layers are, um, layered, meaning that what happens on a ‘higher’ Layer will appear in front of what 
happens on a ‘lower’ Layer on the Stage. The Layer Toolbar and its features are described in the following 
graphic. The descriptions are short because these features are fairly self-explanatory. In order to really learn 
the features, you should play with them. Try to add a Layer and then draw some shapes or place some 
Symbols on each of them. Notice how they appear on the Stage.  

Preview Box 

Library Options 

List of Symbols 
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There are a couple of special functions that Layers can have when used in animations. We will talk about 
some more advanced Layers when we cover animation with Guide and Mask Layers. 

Animation 
There are a couple more concepts to familiarize yourself with before we’re ready for the animation exercises. 
First, creating animations requires that we get more intimate with the Timeline in Flash. The Timeline will 
indicate, for a given Layer, what things are happening when. The ‘when’ is in terms of frames, and the 
default rate at which Flash movies play is 12 frames per second (you can adjust this in the Movie Properties 
box, Modify > Document).  
When you want to specify that a certain action will happen in a given frame, you will add what’s known as a 
Keyframe to that frame. The Keyframe is indicated by a black dot within a frame. You can add a Keyframe 
by clicking in the desired frame and either typing F6 or clicking Insert > Timeline > Keyframe. Adding 
Keyframes is to be distinguished from adding frames (typing F5 or clicking Insert > Timeline > Frame) in 
that Keyframes will indicate action or change while frames will indicate a static continuation of the 
preceding Keyframe. You might add frames in order to extend a static background for your movie. 

 

 

 

 

 
 
 
 
 

Layer 2’s elements will 
appear in front of 
Layer 1’s elements on 
the Stage. 

These buttons are 
for adding a 
Layer, a Guide 
Layer, or a folder, 
respectively. 

The Trash button 
allows you to delete 
a selected Layer. 

Layer 2 is 
highlighted 
and has a 
pencil 
marking, 
meaning it 
has been 
selected 
(mouse-
clicked) and 
therefore its 
contents on 
the Stage can 
be edited. 

Clicking the Eye of a Layer can 
make its contents visible or 
invisible on the Stage. 
The Lock can prevent a Layer’s 
contents from being modified. 
The Square means a Layer’s 
contents are viewed in outline 
form. 

Timeline 

Frame marker (red thingy) 
that indicates which frame’s 
contents are appearing on 
the Stage. 

Keyframes 
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Ways to preview your animations 
When you start to create animation, you will eventually want to preview your work. There are several ways 
to do this in Flash MX. By far the best way to preview your animations is to do so in Test Movie. This will 
allow you to view your work as it would appear in Flash Player, as a *.swf file. To use this preview method 
just press Control-Enter, or go to Control > Test Movie on the Main Toolbar. Notice that unless specified 
through a Stop Action the animation will play over and over again until you close the Flash Player’s window. 

Another way to preview your work is to do so as it would appear in an internet browser. Here you’ll first 
have to save your animation as a flash file (*.fla) by clicking File > Save. Then you can click File > Publish 
Preview > and either default - (HTML) or HTML. Notice that the Flash option you see under File > 
Publish Preview is another way to use the Test Movie and play the animation in Flash Player. The advantage 
of previewing your work in either Flash Player or in an internet browser is that they allow you to view your 
animations almost exactly as they will appear to your viewers. 

Should you ever wish to preview your animations on the Stage in the Authoring Environment, you have two 
options. First you can use the Controller by clicking Control > Play from the Main Toolbar. You could also 
view the Controller options like other Toolbars appear by clicking Window > Toolbars > Controller. The 
second way to preview animations on the Stage is to use what savvy animators call ‘scrubbing’. To scrub, 
just grab that red frame marker on the Timeline and drag it forward and backward on the Timeline. Either 
of these approaches will allow you to preview your work within the Authoring Environment. They have 
disadvantages to the other preview methods in that you may not automatically view all of your activity as it 
previews in the Authoring Environment (e.g., the actions of your buttons), or, in the case of scrubbing, view 
it at a constant play rate. 

Frame-by-Frame Animation 
If you have intricate drawings that are supposed to change in very subtle ways across frames, you may want 
to make these changes on a frame-by-frame basis. While this method of animation can be tedious and 
demanding on file size, if you are a professional animator with very specific effects in mind, you may need 
to make frame-by-frame animation. 

To get a sense of frame-by-frame animation, open a new Flash document (File > New). Draw an initial 
shape of something. Now click on frame 2 and create a Keyframe in it (F6). The shape you drew in frame 1 
should appear in selected form in frame 2. Now alter this shape in some noticeable way by adding an 
additional shape or changing the current shape’s color, scale or rotation. Repeat this process of adding a 
Keyframe to the next frame and altering the shape until you have several Keyframes for the changing shape. 
Now preview the animation in Test Movie (Control-Enter). 
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Onion skinning. 
If frame-by-frame animation is something you will be doing a lot of, you may want to consider using Flash’s 
onion skinning tools, located under the Timeline. These allow you to view the contents of previous frames 
as you alter them in the current frame. Think of how animation was created in the days before computers: 
Hard-working people would have to draw the contents of each individual frame, making small changes in 
order to depict smooth movements. It was helpful for them to draw images on thin paper, onion skin paper, 
which they could place on top of the images of previous slides. They could then basically trace the preceding 
images but with small changes. The figure below gives you a picture of how onion skinning might be useful. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tweening Animation 
If frame-by-frame animation seems like tedious and undesirable work, be aware that you have other options 
for animation. These are usually much more efficient and easier on file size. The idea of tweening is that we 
don’t have to draw what happens in every frame. Instead we specify what happens on a beginning frame 
and an ending frame and then let Flash fill in the rest. The next sections walk you through the four major 
types of tweening: motion, shape, and tweening with guide and mask layers. 
 

Onion skinning Tools 
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Motion Tweening 
Let’s say your animation consists of some shape that’s supposed to move from one spot on the Stage 
directly to another spot within a given number of frames. In that case, your best option might be motion 
tweening. Here is the walk-through: 

1) Open a new Flash document (File > New). 

2) Draw a shape on the Stage, select it and convert it to a Movie Clip Symbol (Insert>New Symbol or type 
F8). 

3) Select a later frame in the Timeline and insert a Keyframe in it (Insert>Keyframe or F6). 

4) Select the first Keyframe in frame 1 and specify the initial position of the shape. 

5) Select the later Keyframe and specify the ending position of the shape. 

6) Select the first Keyframe and open the Properties Panel (Window > Properties) 

7) Go to the Tweening drop-down list of the Frame Panel and Select Motion.  

 

 

 

 

 

 

8) Notice the arrow that now connects your two Keyframes on the Timeline. This indicates the Motion 
Tween. 

 
 
 

 

9) Preview the animation in Test Movie (Control-Enter). 

10) In addition to these steps, you could also take advantage of some of the other options in the Frame 
Panel once you have selected tweening. For example, the Easing option lets you specify whether you 
want the motion to begin fast and end slow (Ease-Out) or begin slow and end fast (Ease-In). The Rotate 
option is for making your shape rotate as it moves from the beginning to ending frame. 

Note: The motion can only be applied to shapes that are grouped and to layers with only one group or 
symbol.  To add motion to multiple symbols, use a different layer for each symbol.  To group objects, 
select the objects to be grouped and go to Modify > Group.  

Shape Tweening (Morphing) 
Say you want an animation that makes one shape change (morph) into another. You could get this effect by 
tweening a shape. This procedure will not work with Groups or Symbols. Also note that shape tweening can 
rapidly increase your file size and thus lead to slower playing times for your viewers. But it can also be a 
pretty cool effect. 

1) Open a new Flash document (File > New). 

2) Draw the initial shape onstage. Don’t group it or convert it into a Symbol. 

3) Insert a Keyframe in some later frame (Insert > Keyframe or F6). 
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4) Alter the original shape in this later frame, or first draw a new shape and then delete the old one (Note 

that if you use text for this end shape you will want to select the text and then click Modify > Break 
Apart for the shape tween to work). 

5) Select the initial Keyframe, open the Properties Panel and set Tweening to Shape. Notice the tweening 
arrow that now connects the two Keyframes in the Timeline. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

 

1) Preview this in Test Movie (Control-Enter). 

2) Sometimes Flash’s shape tweens don’t happen exactly as you would like them to happen. For unruly 
transitions try Shape Hints. (See page 193-197 of SAMS: Teach Yourself Macromedia Flash 5 in 24 
Hours). 

3) The Easing option controls the rate of the shape change from its start to its end. Ease-In means the 
tween starts slowly and then speeds up. Ease-Out means the tween starts fast and then slows down. 

4) Blend: Distributive blend means the intermediate shapes are smoother and more irregular. Angular 
Blend preserves the corners and straight lines in the intermediate shapes. 

 
Guide Layers 
If you want the motion of your motion tween to be anything other than a straight line, you may want to use 
a Guide layer. Here you tell Flash how to move an initial shape to a different position.  

1) Open a new Flash document (File > New). 

2) Select the Pencil drawing tool and use it to draw the path for an object to follow. 

3) Select Modify> Timeline > Layer Properties to access this Layer's Properties. Change the Layer to 
Guide. (You can also right click the layer and click properties.) 

4) Insert a new layer by selecting Insert > Timeline > Layer. 

5) Drag this new layer below the path layer. This causes the new layer to be Guided (see its properties) and 
the dashed line now separates the two layers. 

6) Draw the shape to move along the path in the first fame of the Guided layer. Select it and convert it into 
a Movie Clip Symbol (F8).  

7) In the Guided layer click the ending frame for the path and insert a Keyframe (F6).  

8) In the Guide Layer where the path is insert a frame at this ending frame (F5).  
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9) Click on the first frame of the new layer and create a Motion Tween by selecting Motion from the 

Tweening drop-down menu of the Frame Panel. 

10) Check the Snap box in the Frame Panel for the first frame of the new layer and move the shape to the 
beginning of the path. *The shape’s registration point (+) MUST be on the path or Guide Layer 
Motion will not work.* 

11) Click on the ending frame for the new layer and snap the registration point of the shape to the end of 
the path. 

12 Notice that Orient to Path is an option in the Frame Panel whereby the shape being tweened will rotate 
toward the direction it’s traveling. 

Preview this animation in Test Movie (Control-Enter). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Motion Tween 
Guide Layer is above the 
Guided Layer 

Symbol's 
registration 
point (+) is 
on the path. 
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Mask Layers 
The animation effect achieved through the use of mask layers is difficult to describe but easy to understand 
once seen. It's basically a spotlight effect. Follow these instructions and just see what you think about this 
method of animation. 

1) Open a new Flash document (File > New). 

2) Draw a filled circle, select it and convert it to a Movie Clip Symbol (F8). 

3) Insert a Keyframe in a later frame (F6) and move the circle to a new location. 

4) Click on the initial Keyframe and set up Motion Tweening through the Tweening menu on the 
Properties Panel. 

5) Access the layer’s properties (Modify > Layer) and change this layer to Mask. 

6) Add a new layer (Insert > Layer) for the objects the spotlight will show/hide. 

7) Drag this new layer below the Masking layer so that it becomes a Masked Layer.  

8) In this new layer, draw the shape to be spotlighted (Text works well for this) and move it so that it's in 
the path of the circle in the Mask Layer. 

9) Preview the animation in Test Movie (Control-Enter). 

10) Some masking limitations: 
a. No more than one symbol in the Mask layer. 
b. No combining Guide and Mask Layers. 
c. When you place a Movie Clip symbol in a Mask layer it acts like a Graphic symbol. 

Interactivity: Button Symbols 
One of the main ways to make web-based animations more interactive is through the use of buttons. These 
Symbols will be the focus of this section. The discussion of more sophisticated forms of interactivity, such 
as Flash's programming language (ActionScript), sound, and the use of Smart Clips, is left for another day. 
Here, then, is a brief introduction to Button Symbols: 

1) Open a new Flash document (File > New). 

2) Go to the Main Menu and click Insert > New Symbol. Name it and make it a Button Symbol. Click OK. 

3) You are now in Symbol-Editing Mode for a Button. It should look like the figure on the following page. 

 
You will want to specify four states for this button. Each of these frames will need a Keyframe (press F6 
when the frame is selected) and then you will define the contents of each of the four states. 

-Up: This is the appearance of the button when it is 'at rest', or unselected or in contact with the mouse. 
-Over: This is the appearance of the button when the user moves their mouse over it. 
-Down: This is the appearance of the button when the user clicks it with their mouse. 
-Hit: This is where you define what area constitutes when the mouse contacts the button and when it 

doesn't. No one will see this shape, but the size can impact how people interact with the button. 

When you have defined these states, you can return to the Authoring Environment (Edit > Edit 
Document).  Open the Library (Control-L), find the Button and drag it onto the Stage. 

Preview the animation in Test Movie (Control > Enter). Test the button by mousing over it and clicking it. 
You can run the Button Tutorial in Flash to get more practice at using Buttons (Help > Using Flash > Using 
symbols, instances, and library assets > Creating Buttons).  
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Making buttons even more interactive requires that we get into ActionScripting. Examples of actions you 
would assign Instances of Buttons are to indicate that when a particular button is clicked: 1) to open some 
web page, 2) to go to a particular frame in the movie, 3) to alter some variable. You can learn these actions 
and more in the manuals cited at the end of this document. 
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Animation publishing and viewing 
When your animation is ready for internet publishing, you will have some other choices to make. One big 
choice is how you prefer viewers to see your movie: as played on Flash Player or in an internet browser, or, 
probably less desirable, as static images. These options are available under File > Publish Settings.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

You will want to save your Flash file first (*.fla). Then when you set your publish settings, you can just click 
Publish and the file(s) will be saved where your Flash file has been saved. 
The advantage to publishing a Flash Player file (*.swf) is that animations will look the same for most users 
because Flash Player plays similarly and is widely and freely available (for the download site see the 
Macromedia website listed below). You will still need to embed this file in some other HTML file so that it 
is available to web users viewing a web site.  
Using the HTML file from the Publish settings allows users to view the animation directly within an internet 
browser. The quality can vary more widely than it does with Flash Player files. 
You can use the File > Export > Export Movie options to get even more options for your animation. 

Options for the 
Type(s) selected 
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Beyond this Handout 

Websites for help and inspiration 
The following websites have been around for a while. They contain tutorials and professional work that can 
give you more ideas for Flash animation. 
 
http://www.macromedia.com/support/flash/ 
http://www.flashkit.com 
http://www.virtual-fx.net/ 
http://www.flazoom.com/ 
http://www.flashmagazine.com 
http://www.were-here.com 
http://www.webdevelopersjournal.com/articles/flash/flash_intro.html 
http://www.w3schools.com/flash/default.asp 

Manuals at CSSCR 
There are several very good manuals at CSSCR. The manuals are available for check-out to affiliates of the 
University of Washington. Just present your driver’s license to a qualified CSSCR Software Consultant and 
ask to see the Flash Manuals. 

Lessons and Samples within Flash MX 
You can also get more help directly within Flash. I’ve directed you to relevant tutorials but you can also 
check out the Samples under Help. These are professional examples of many of the things Flash can do. 
You can view these samples with the Movie Explorer, which provides an organized and highly-readable 
view of a Flash file, not to mention an easy way to make certain edits (Window > Other Panels > Movie 
Explorer).  

Flash MX's Common Libraries 
Finally, you can browse Flash’s pre-made buttons, sounds, graphics, etc, as potential additions to your own 
work. These are found under Window > Other Panels > Common Libraries. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tim Moses, 4/02 (Revised by Chris Rothschild, 1/05) 
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